Технические требования

Для успешной работы компонента ваш сервер должен соответствовать техническим требованиям актуальной версии Joomla:

  • PHP 5.3.10+ (рекомендуется 5.4+). Для поддержки многоязычности минимальной версией является 5.4.
  • MySQL 5.0+ с поддержкой InnoDB. Для оптимальной производительности рекомендуется версия старше 5.5.
  • Веб-сервер: Apache 2.x+ с поддержкой mod_mysql, mod_xml и mod_zlib. Либо Nginx веб-сервер.

PHP настройки

  • max_execution_time >= 30
  • memory_limit >= 16M (рекомендуется >= 64M из-за манипуляций с изображениями)
  • safe_mode = off
  • upload_max_filesize >= 3M
  • Поддержка DOM, JSON и Multibyte String
  • GD или ImageMagick

Совместимость с версиями Joomla

  • NorrCompetition 1.7.3+ -> Joomla 3.7 и выше
  • NorrCompetition до 1.7.0 -> Joomla 3.4.0 - 3.6.5

Прочие требования

Для работы компонента NorrCompetition требуется библиотека jQuery (версия 1.11.2 и выше), которая подключается из ядра Joomla 3 по умолчанию. Если вы оптимизируете сайт и отключаете лишние скрипты, удостоверьтесь, чтобы jQuery не была отключена. Подключение MooTools не требуется.