Can't save changes in JMB Tree Pro

2 months 14 hours ago #3648 by David Dom
Topic Author
David Dom's Avatar
Posts: 4
Hello,

I am having the same issue. Changing the value is not possible, I tried through htaccess and Plesk.

But the free version already does what I want, except for one detail which I hoped would be resolved in the commercial version, but now I can't even test if it is or not.

The problem is, as you can see in attached image, that there are dots in front of each menu item. I can't seem to get them away with CSS no matter what I try.

Can you please advise?

Attachments:

1 month 4 weeks ago #3649 by Eugene
Eugene's Avatar
Posts: 802
Hi David,
It seems there are 2 different problems.

1. You are not able to save module.
2. Dots in front-end.

Problems with saving settings occur due to the memory limit on your hosting and a lot of menu items.
It happens since the module processes each menu item and if there are a lot of them, it potentially can lead to problems, which fortunately can be resolved by increasing limits.
I can advise to contact the hosting provider and increase memory limit.
Btw, how many menu items are used on your site?

As for dots - it happens due to conflict of styles. It's kind of customization.
Try to use another module style or assign another Joomla template to make sure the problem is due to Joomla template.
Btw, what Joomla template is in use on your site?

Like our extensions and support?
Add your voice to the JED listing with a 5 score review:: bit.ly/2ciJBqC
Thanks!

1 month 4 weeks ago #3650 by David Dom
Topic Author
David Dom's Avatar
Posts: 4
Hello,

I have in the meantime moved to another module menu altogether which fixed all my problems at once.

As for being unable to save the module, the menu I wanted to use it for was Kunena forums, so not even a very large menu. But it didn't matter, even if I didn't assign a menu to the menu module, it would still not let me save anything. To be honest, I am not very keen on using a module that requires so much memory for merely a menu, whereas other modules, with often much lager menus, work like a charm without needing extra energy. If I had known this in advance, I would not have purchased it.

As for the dots, yes it may be template related, I use a template called "Eco" which was originally for an older Joomla version but the developer updated it for me to work with the current Joomla versions too. However, only this particular menu module was causing the dots to appear, and the several others I tried did not.

But, as I said, I am now using a different menu module altogether so the menu I urgently needed is resolved.

1 month 3 weeks ago #3655 by David Dom
Topic Author
David Dom's Avatar
Posts: 4
Hello,

I thought I'd let you know that I was finally able to modify php.ini on my server. I changed the vars value (which you suggested to the other person in the previous topic about this) even as high as 8000. And still it doesn't work, but now when trying to save the module, it gives me this error:

Save failed with the following error: The content exceeds allowed limits

And then no changes are saved in the module. I have never had this error before.
The amount of menu items for that menu doesn't seem to matter - I even tried with a very small menu of only 2 menu items, and it still gives me that.

Also, when opening the module settings in the admin panel, it always takes several seconds to load, and then when trying to save it takes several seconds. I have never known any other module to do this.

While my own issue is already resolved, as I said before, by switching to another module, I still wanted to let you know this. I don't have any other memory issues on my site and server whatsoever, everything runs smooth despite the fact that I run a large Joomla site.

1 month 3 weeks ago #3656 by Eugene
Eugene's Avatar
Posts: 802
Hi David,
We are sorry you faced some problems.
Website design is something when 3rd party factors can cause the issue.
as you can see - the module works on the demo, however, there is an issue caused on your site and it requires investigation.
Perhaps there is a server environment with limits on your side...
If you need help, please send credentials (admin and FTP) and a direct link on the page with module for investigation the problem.

Like our extensions and support?
Add your voice to the JED listing with a 5 score review:: bit.ly/2ciJBqC
Thanks!

You can get our help: Monday - Friday / 09:00 to 17:00 (GMT+2). but not limited. Our staff will be pleased to provide Premium support to every paid subscriber asap, but sometimes you should be ready to wait for our reply for up to 3 days. In case of free extensions we do the best to develop and maintain them either, but their support is not necessary.

Follow us in social media