Can't create an entry

2 months 1 week ago #2342
Topic Author
Nick Vine's Avatar
Posts: 10
Can't create an entry

Hi

We have set up a category, fields (including a title), and a contest.
However when we try to create an entry we get a JFile error: prnt.sc/ot3ru8
Can you please help... this process is proving very difficult!
I'm happy to provide these credentials:

This message contains confidential information


The log file says this...
This message contains confidential information

Last edit: 2 months 1 week ago by Dmitry.

2 months 1 week ago #2343
Eugene's Avatar
Posts: 553
Can't create an entry

I guess the problem is in Fast-CGI. Please try to enable the Apache handler.


The Fast-CGI issue will be fixed in the NorrCompetition version 1.8.0.


Like our extensions and support?
Add your voice to the JED listing with a 5 score review:: bit.ly/2ciJBqC
Thanks!
Attachments:
Last edit: 2 months 1 week ago by Eugene.

2 months 1 week ago #2344
Topic Author
Nick Vine's Avatar
Posts: 10
Can't create an entry

Siteground say this:

"The web server running is Apache and that you can use the Handlers you need as well"

2 months 1 week ago #2345
Dmitry's Avatar
Posts: 677
Can't create an entry

Hi Nick.

Strange issue, needs more debugging. Is it your dev site and I can you use any debug on it?

Best regards,
Dmitry


Like our extensions and support?
Add your voice to the JED listing with a 5-score review: bit.ly/2ciJBqC
Thanks!

2 months 1 week ago #2346
Topic Author
Nick Vine's Avatar
Posts: 10
Can't create an entry

You can make changes in the staging site... no problem.

2 months 1 week ago #2347
Dmitry's Avatar
Posts: 677
Can't create an entry

Well I've managed to solve it :whistle:

First of all I have disabled "Scan uploaded files" on jHackGuard, because it does not allow to upload files normally. See this tip:
www.joomlashack.com/docs/oscampus/troubl...s-parameter-1-error/

Secondly I fixed interesting issue that I was never faced before. In some environments there is a problem interpreting URL generated with Joomla API as a string. I cannot identify clearly why does it happen, but probably when URL consists of third/fourth level domain. This caused problems in getting the filename of the uploaded image.

Anyway I have implemented more cleaner approach that helped to fix it. This will be implemented in upcoming 1.8 version (plan to release it in the end of August).

If you will be moving to production environment before 1.8 release, please contact us and I will provide you with the fix on your production website.

Dmitry


Like our extensions and support?
Add your voice to the JED listing with a 5-score review: bit.ly/2ciJBqC
Thanks!
Last edit: 2 months 1 week ago by Dmitry.

2 months 1 week ago #2348
Topic Author
Nick Vine's Avatar
Posts: 10
Can't create an entry

Thanks for your efforts Dmitry.
I really need to get this deployed early next week.
I will destroy this staging copy and create a clean version.
I’ll then turn off the jHackGuard scan on upload and reinstall 1.7.8.
If you can supply the code change, we can implement them and report the result.

2 months 1 week ago #2349
Dmitry's Avatar
Posts: 677
Can't create an entry

The same change should be made in two files: admin/controllers/participant.php and site/controllers/appform.php

Old code:

$newPhoto = str_replace(NC_URL_PHOTOS . '/tmp/', '', $this->input->getString('photo', ''));
New code:
$newPhoto = basename($this->input->getString('photo', ''));

Dmitry


Like our extensions and support?
Add your voice to the JED listing with a 5-score review: bit.ly/2ciJBqC
Thanks!
Last edit: 2 months 1 week ago by Dmitry.

2 months 1 week ago #2350
Topic Author
Nick Vine's Avatar
Posts: 10
Can't create an entry

Hi Dmitry

I did what I said I would do... created new staging2 area, deselected "scan uploaded files", and uploaded the install package for 1.7.8
However, as soon as I upload the install, I get this error (screenshot):

This message contains confidential information

There is no evidence that anything has been installed, but if you go to extensions > manage > manage > and search for "nor"... you get this:
This message contains confidential information

If you uninstall that artifact, and return to the install process and try to install the package again, it reports that installs successfully.... so something "unseen" must have been installed or a table created on the first attempt I guess!

I then made the 2 code changes and so far in tests it seems okay.
This message contains confidential information

2 months 1 week ago #2351
Dmitry's Avatar
Posts: 677
Can't create an entry

The error I see on your screen is not produced by extension itself because there is no such SQL query in the installation SQL file. For some unknown reason Joomla extensions installation routine is trying to perform ALTER TABLE on table that does not exists. I have no idea at the moment why it is happening. I will try to test it on my local environment.


Like our extensions and support?
Add your voice to the JED listing with a 5-score review: bit.ly/2ciJBqC
Thanks!

You can get our help: Monday - Friday / 09:00 to 17:00 (GMT+2). but not limited. Our staff will be pleased to provide Premium support to every paid subscriber asap, but sometimes you should be ready to wait for our reply for up to 3 days. In case of free extensions we do the best to develop and maintain them either, but their support is not necessary.

Product Latest Update