Open Graph Dimensions

7 months 3 days ago #2774
Topic Author
Nigel Maine's Avatar
Posts: 1
Open Graph Dimensions

Hi Eugene

I read your post about adding dimensions to the NorrNext Zoo OpenGraph Plugin. And instructions...

Open /plugins/system/zooopengraph/zooopengraph.php

Find lines 114-115, 231-232 and 392-393:

// Image
!empty($opImage) ? $script[] = '<meta property="og:image" content="' . JURI::root() . $opImage . '"/>' : false;

You can add required tags there according to The Open Graph protocol like this example:
<meta property="og:image:width" content="400" />
<meta property="og:image:height" content="300" />

2. You need to open zooopengraph.php file again and find line 77:
$opImage = $this->params->get('image', 0);

Find lines 114-115, 231-232 and 392-393:

// Image
!empty($opImage) ? $script[] = '<meta property="og:image" content="' . JURI::root() . $opImage . '"/>' : false;

I got as far as looking at the above PHP code and the lines you referred to but couldn't understand what to do at line 77.

And I couldn't work out how to enter the two respective lines of code at to lines 114-115, 231-232 and 392-393 to enable me to enter og:image:width and og:image:height as I have never worked with PHP, only to add or replace what a forum or blog post has suggested.

I resized all my images to 1200px wide as per your instructions and read the linked Facebook page about image size which says a minimum of 1080px.

However, when I put the url in the Facebook Debugger to be scraped, it comes up with the error message:

Inferred Property
The provided 'og:image' properties are not yet available because new images are processed asynchronously. To ensure shares of new URLs include an image, specify the dimensions using 'og:image:width' and 'og:image:height' tags.

I would be very grateful if you could fill in the gaps to help me enter the code properly.

Many Many thanks in advance.

Kind Regards

Nigel

7 months 2 days ago #2777
Eugene's Avatar
Posts: 654
Open Graph Dimensions

Hi Nigel,

This topic is posted in the wrong forum section. You have registered a new account and thereby have no permissions to post a topic in the correct section.

The user gets access to downloads area for product updates and technical support during the period of the subscription validity.
Open Graph for ZOO gives a 12-month subscription. When it's expired, the user still can use the product, but get no access to updates and support.

I've found your old user account which was registered in 2016, so I suppose you're using an outdated version of the element. I recommend you to buy the subscription and use the latest version of this product. If the problem still will remain, then we will back to this question.

Regards,
Eugene


Like our extensions and support?
Add your voice to the JED listing with a 5 score review:: bit.ly/2ciJBqC
Thanks!
Last edit: 7 months 2 days ago by Eugene.

You can get our help: Monday - Friday / 09:00 to 17:00 (GMT+2). but not limited. Our staff will be pleased to provide Premium support to every paid subscriber asap, but sometimes you should be ready to wait for our reply for up to 3 days. In case of free extensions we do the best to develop and maintain them either, but their support is not necessary.

Follow us in social media