Stripe dashboard set to 2020-08-27 and plugin is 2020-03-02 Phoca Cart

1 year 3 months ago - 1 year 3 months ago #3527 by David Leeman
Topic Author
David Leeman's Avatar
Posts: 45
Hi

I've got an issue where the plugin is installed and set up with API keys and webhooks but the Stripe account (set up 4th Feb 2021) is set to

2020-08-27 (default) (latest)

The Plugin is 2020-03-02

My end client set up their Stripe account and I have developer access as their tech skills are more basic.

So, I have set up a test sandbox payment and Live payment, but set the plugin to sandbox

In Stripe I can see incomplete transactions - no card data entered

this makes sense as when Phoca Cart tries to re-direct to Stripe I just get a brief message at the bottom left of the view portal stating - waiting for (my domain name)

Then nothing, it just sits on that screen (with the Phoca Order message and the Stripe Payment button), Phoca then places the product into pending.

In Stripe the order number and amount are shown but of course the transaction is incomplete.

Any ideas?

Do you think as the Stripe account is so new that they could roll back the API version to match?

The help on Stripe is very 'flow chart' so any insights you have would be valuable while the account is less than 72 hours old - this is the time limit for any rollback

Regards
David
Last edit: 1 year 3 months ago by David Leeman. Reason: typos and clarity
The topic has been locked.
1 year 3 months ago - 1 year 3 months ago #3528 by Eugene
Eugene's Avatar
Posts: 934
Hi David,

The API will be updated in the next version of our plugin, but current version of the plugin is compatible with the latest API version.
We need more information.
Please enable debug mode in Phoca Cart and provide us the details taken from Phoca Cart system log (it might be a screenshot).
You can use Confidential tag here to hide the information or send it at This email address is being protected from spambots. You need JavaScript enabled to view it.

Thanks.

Like our extensions and support?
Add your voice to the JED listing with a 5 score review:: bit.ly/2ciJBqC
Thanks!
Last edit: 1 year 3 months ago by Eugene.
The topic has been locked.
1 year 3 months ago #3529 by David Leeman
Topic Author
David Leeman's Avatar
Posts: 45
I turned on Enable Logging (on - ALL) in Phoca Cart (dashboard>options>main)

then tried a transaction. Again this hangs on the Stripe re-direct page.

Checked log info, but it was empty

I checked the Phoca Cart forum and found this post, www.phoca.cz/forum/viewtopic.php?f=44&t=...logging+info#p163999

So maybe Phoca Cart is not recording the problem?

I know it is close to working as there is some activity shown in Stripe, but it's not giving me much information to pass on!

Is there anything else I can provide for you? Joomla Debug perhaps?

Regards
David
The topic has been locked.
1 year 3 months ago #3530 by David Leeman
Topic Author
David Leeman's Avatar
Posts: 45
Please find attached the output from the Stripe dashboard on my test/sandboxAgain, this is without the Card payment step, as this page does not yet appear.I have tried Chrome and Firefox but the site still just seems to hang on Pay with Stripe page, or rather there is no re-direct to the Stripe apyment process.Attachment is a Paste/Copy into a PDFRegardsDavid
Attachments:
The topic has been locked.
1 year 3 months ago #3531 by Eugene
Eugene's Avatar
Posts: 934
David,
We need to reproduce it.
Please send credentials to your site and URL of the product. You can send it at This email address is being protected from spambots. You need JavaScript enabled to view it. or use Confidential tag here.

Like our extensions and support?
Add your voice to the JED listing with a 5 score review:: bit.ly/2ciJBqC
Thanks!
The topic has been locked.
1 year 3 months ago #3533 by David Leeman
Topic Author
David Leeman's Avatar
Posts: 45
Thanks Eugene

I've posted a couple of messages to the support@ address. There should be one for the login to the site too

Regards
David
The topic has been locked.
1 year 3 months ago #3534 by Eugene
Eugene's Avatar
Posts: 934
Hi David,
I signed in to your site under testuser and proceed to the checkout - there is PayPal payment option only.
Please prepare your site for testing Stripe.

To remind:
1. Stripe appears inside the checkout page (no redirection to the external page).
2. I recommend disabling all caching extensions to make sure they are not impacting on scripts.
3. If no success, you can create a subdomain and install clean Joomla and Phoca Cart there and make tests with payments to make sure the problem is not in the scripts.

Good luck!

Like our extensions and support?
Add your voice to the JED listing with a 5 score review:: bit.ly/2ciJBqC
Thanks!
The topic has been locked.
1 year 3 months ago #3535 by David Leeman
Topic Author
David Leeman's Avatar
Posts: 45
Hi Eugene

Thank you for your time and advice, it is greatly appreciated.

I think it's working

After double checking everything I did discover the following:
1) I missed adding the test user to the Phoca test group - this is now done
2) reduced the JCH Optimise cache until the card form field data appeared
3) Successfully completed a sandbox order with a Stripe dummy card!

Ok, some major progress

I'll let the cache settle down overnight and try it in the morning

Many thanks Eugene

Regards
David
The topic has been locked.
1 year 3 months ago #3537 by Eugene
Eugene's Avatar
Posts: 934
Hi David,
I am glad the problem is resolved now.
Do not hesitate to contact us in case of any questions.

We would be grateful if you leave a review about this plugin at the JED.

Regards,
Eugene

Like our extensions and support?
Add your voice to the JED listing with a 5 score review:: bit.ly/2ciJBqC
Thanks!
The topic has been locked.
1 year 3 months ago - 1 year 3 months ago #3548 by David Leeman
Topic Author
David Leeman's Avatar
Posts: 45
Yes, I'd be happy to leave a review on the JED.

The plugin is very good value for money, and your support has been excellent. I shall add one later this evening

UPDATE: review posted on JED

Kind regards

David
Last edit: 1 year 3 months ago by David Leeman. Reason: update
The topic has been locked.

You can get our help: Monday - Friday / 09:00 to 17:00 (GMT+2). but not limited. Our staff will be pleased to provide Premium support to every paid subscriber asap, but sometimes you should be ready to wait for our reply for up to 3 days. In case of free extensions we do the best to develop and maintain them either, but their support is not necessary.

Follow us in social media